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Data Reference in DOORS

®* On a complex product development project, high-level requirements for
the system are developed and decomposed into derived requirements for

subsystems and components.

* Lower-level
specifications for
requirements,
design, and
Interface
specifications
need to
reference data
from high level
specifications.

Subsystem
ICDs

Subsystem

Component
ICDs

PIDS = Prime Item Development Specification
CIDS = Critical Item Development Specification
$SDD = System Segment Design Description

ICD = Interface Control Document
Subsystem
S5DDs

Component
SSDDs
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Data Reference using Links

®* DOORS uses links to associate data in one Module with data
In another Module.

® Layout DXL in a column can “pull” the data from the one
module to the other dynamically.
— This data does not appear in the DOORS “main” column.
— Data appears in a separate column.
— Exports to Word “Book” form as an attribute.

« Export format: “Layout Column Name : Layout Column Value”
« “Paragraph Style” ignored for Word style formatting.

® Since this data is not actually written to the module, DOORS
archives do not contain the data when they are restored in
another database.
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“Dynamic Linked Cells”

® To solve these issues, a technique called “Dynamic Linked
Cells” was developed in DOORS.

— Allows “Virtual Objects” to be created that dynamically update
their content by following an out-link to a target object.

— Data is copied to a DOORS table cell in the DOORS “main”
column.
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*

*.\ Application - Managing SWaP-C Data

* SWaP-C (Size, Weight, Power, and Cooling)

— Allocation and estimate data for each subsystem and component
of the product.

* SWaP-C data is referenced in many specifications (SSDDs,
ICDs, etc.)

* Placing this data in single DOORS module, and using Dynamic
Linked Cells to reference the data, allows each specification to
be automatically kept up to date and synchronized with the
master SWaP-C data table.

®* The SWaP-C data table is composed of rows and columns.

— Rows are the subsystems and components which are represented
as DOORS objects.

— Columns are the SWaP-C data which is represented as DOORS
attributes.
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SWaP-C Data Table for Weight

®* The SWaP-C data table is composed of rows and columns.

— Rows are the subsystems and components which are represented
as DOORS objects.

— Columns are the SWaP-C data which is represented as DOORS
attributes. Column (DOORS Attribute)

y
Row (DOORS Object) :I Cell
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“Dynamic Linked Cells” - Implementation

®* The goal is to implement a method to allow specifications to
reference data “cells” in DOORS modules, and keep the data
updated.

® The implementation of “Dynamic Linked Cells” combines three
unique features of DOORS:
— Attribute DXL
— The Attribute property of DOORS Tables
— Link Attributes
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Attribute DXL

* DOORS allows “Attribute DXL"” code to be associated with an attribute.

* Attribute DXL updates the values of the attribute for objects in the module
when a module is opened, or when a user selects “Tools -> Refresh DXL
Attributes” in a Module window.

* Attribute DXL uses two pre-declared variables (attrDXLName, obj) to determine
what attribute is being updated, and what object is being updated for each
execution of the code:
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Definition of “Cell Text” DXL Attribute

A DXL Attribute
named “Cell Text” of

| type “Text” must be
installed in each

[ ] source module, and
reference the Attribute
DXL code,
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Table Properties — Attribute Tab

* A DOORS table is composed of DOORS objects that have attributes.

* A DOORS table has a property that specifies the value of the attribute to
be displayed in the table cell.

* This attribute can have associated Attribute DXL.

]
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Inserting a “Dynamic Linked Cell”

* To facilitate ease of use when creating a “Dynamic Linked Cell”, DXL
functionality has been created to automate these steps for the user.

— “Dynamic Linked Cell -> Insert -> After/Below”
® This DXL functionality:

— Creates the cell
— Removes cell borders
— Sizes the cell

— Sets the attribute property for the table to the “Cell Text” attribute.
* Two versions (Insert -> After and Insert -> Below)
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Inserting a “Dynamic Linked Cell” —
Before “Insert -> Below”
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Inserting a “Dynamic Linked Cell” —
After “Insert -> Below”

Table properties show that
the “Cell Text” attribute is
displayed.

Note: Table cell appears in green because it is selected.
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Linking the Cell to the Target Data

Note: Table cell appears in
pink because it is a link start.
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Attribute Display

* A user of “Dynamic Linked Cells” may want to reference more data than
just the DOORS “Main” Column (Object Heading and Object Text).

®* To achieve this, a “Link Attribute” is used to store the attribute names.

* Link Attributes can be created from the “Edit -> Attributes...” menu in a
Link Module
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Storing Attribute Names
as a Link Attribute Value

* A link attribute named “Target
Attributes” is defined and used
In link modules containing links
from “Dynamic Linked Cells” to
the referenced target data.

® The link references the entire
row, and the attribute name
allows the “Dynamic Linked
Cell” to target a specific “Cell”
(object/attribute combination) in
a DOORS module.
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Edit Link Attribute Value —
Link Module

Editing link attributes through the
link module is a complicated,

multi-step process. A link appears as a dark blue box

Steps:
Q) Locate and open link
module
(2) Locate link
3) Right-click on link, 1;

select “Edit Link”

4 Select Attribute, “Edit
Attribute Value” box
will appear

(5) Set “Value:” toggle to
“Specific”

(6) Type attribute name(s)
in text field.

@) Click “Apply” on “Edit
Attribute Value” box

(8) Click “Close” on “Edit
Link Object” box

9) Close Link Module
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Edit Link Attribute Value —
Source Module

Editing link attributes
through the source
module is a complicated,
multi-step process.

Steps:
(1) Select cell

(2) Select “Link -> Edit
Links...” from menu

3) Select Link, click
“Details...”

(4) Select Link

(5) Click “Details...”
(6) Select Attribute
(7) Click “Edit...”

(8) Type attribute
name(s) in text field

(9) Click “Ok” on
“Attribute Value” box

(10) Click “Ok” on “Link
Properties” box

(12) Click “Ok” on “Object
XX properties” box
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“Set Attributes...” Function

* Because editing link attributes from the DOORS user interface is a
complicated multi-step process, and typing attributes names is prone to
error and inconsistency, a “Set Attributes...” function was developed as

part of the Dynamic Linked Cell implementation.
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“Set Attributes...” Dialog Box

* The “Dynamic Linked Cell -> Set Attributes...” function scans
the target module and displays a list of attributes available in
the target module.
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“Set Attributes...” — Attribute Selection

® The user can then select attributes and “push” them over to the
“Displayed Attributes” list. This list determines the attribute
content and order for the “Dynamic Linked Cell”.
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Attribute Display

* Once the dialog box is closed, the updates will be applied, and the
new data will be pulled.

* Attributes names will appear in bold, followed by the attribute value.
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DOORS “Main” Column

* A special attribute called “Object Heading and Object Text” is available
in the list of available attributes.

— This is used to pull the data from the DOORS “main” column, and is
represented without an attribute label.

— This can be commingled with other attributes in any order.
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Attribute Display Order

The “Object Heading and Object Text”
attribute can be “pushed” over to the
Displayed Attribute list using the left arrow.

When more than one
attribute is displayed,
individual attributes

\ can be selected and
re-ordered to in the list
using the up and down
arrows.

When
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SWaP-C — Data Reference

* For SWaP-C data, the “Object Heading and Object Text” contains the
subsystem or component name. Pairing that with the attribute
containing the data for a specific variant gives a complete representation

of the data.
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SWaP-C — Appending Units

* SWaP-C data has units
(Weight == kg, Power == Watt,
etc.).

* The SWaP-C module stores
these units as Module level
attributes, one for each data
column.

* The “Dynamic Linked Cells”
use this knowledge to append
the units to the data when it is
pulled into the module.

u
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Attribute DXL — Refresh

* Since “Dynamic Linked Cells” are implemented with Attribute
DXL, they automatically update when a module is opened, or
when a user selects “Tools -> Refresh DXL Attributes” in a
Module window.

* In DOORS v7.x, Attribute DXL refreshes data even if the
Module is opened in read-only mode, allowing read-only users
to see the latest data.

— This is desirable when the read-only module being opened is the
“current version” of the Module, but is not desirable when the
read-only module is a baseline version of a module.

® Because of this feature, the “Dynamic Linked Cell” functionality
also copies the information contained in the “Cell Text” attribute
to the standard “Object Text” attribute.

* This facilitates the following operations:
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Baselines

* Data in a DOORS baseline should not change, but Attribute
DXL is executed in baselined modules, and Attribute DXL
cannot be disabled or turned off once the module is baselined.

® To circumvent this problem, the “Dynamic Linked Cells”
Attribute DXL code was written to detect if it is being executed
In a baseline.

— In such a case, the Attribute DXL does not update the attribute
value.

— Instead, it displays the value stored in “Object Text”.
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Archives

* DOORS Archives are used to move entire DOORS modules
between databases.

®* Module Archives are for a single module, and do not carry
any link information with them.

® To allow data pulled into a “Dynamic Linked Cell” to be
persistent, a DXL script is used to disable the “Cell Text”
attribute for “Dynamic Linked Cells”, and the tables are reset
to show “Object Text”.
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DOORS Table Property
“Value displayed in each table cell”

®* The DXL used to set the Table Property of the “Value displayed in
each table cell” is the undocumented function

— (reserved “Main Column Attribute™)
* To set the value displayed in the cells of a table to the “Cell Text”,

attribute, the following DXL is executed on the Table Header
Object:

®* To set the value to the default of “Object Heading and Object
Text”, a null string (*”) value is assigned for all Table Objects.
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DOORS Tables

* In the initial implementation of “Dynamic Linked Cells”, the
cells were intended to stand alone as a single cell.

® Since the adoption of “Dynamic Linked Cells”, users have
expressed a need to build a larger table comprised of
“Dynamic Linked Cells”.

® This update is being evaluated, and may be implemented if
feasible.
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“Virtual Objects” in DOORS

* The concept of creating self-updating, “virtual objects” in
DOORS has been previously conceived and implemented by
others (see Appendix A).

* The main advantages of the “Dynamic Linked Cell” concept
are:
— Since Attribute DXL is used, no Triggers are necessary.

— Since Attribute DXL in v7.x shows updated values in read-only
mode, users see the latest data in all module open modes.

— The “Set Attribute...” tool allows a user to easily select from the
available set of target attributes.

— Referenced attributes appear in the DOORS “main” column, and
are exported with the “main” column to Excel or Word “Book” form
using the standard DOORS exporters.
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Appendix A:
Other “Virtual Object” Implementations:

* Dynamic and Automatic Update of Content Linked from Another
Module Using DXL Triggers

— by John Deely and Nick Nicolai of GE Healthcare Technologies
— Prepared for the 2005 Telelogic Americas User Group Conference

— http://www.telelogic.com/campaigns/2005/americas/ugc/abstracts.cfm?ID=

4130&from=wed

* Comparative Evaluation of Product Line Requirements Architectures

— Developed at Honeywell by Robert H. Fall, Jennifer Stieglitz, Robert
Schlachter, Karen Protola

— Presented at the 2001 Telelogic Americas User Group Conference

* Virtual Objects? Virtually!
— by E. M. O’Keefe — Raytheon Company
— Presented at the 2000 INDOORS Americas User Group Conference
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Appendix B: “Dynamic Linked Cells”
Download and Installation

* The "Dynamic Linked Cells" software can be downloaded from the
following URL.:

— http://www.galactic-solutions.com/GalacticDownloads.htm

* The downloaded .zip file will contain the following files:

* Extract these files to the "user" directory within the DOORS client
installation. The following example location is for a DOORS 7.1
installation:

C.\Program Fi | es\ Tel el ogi c\ DOORS 7. 1\ | i b\ dx| \ addi ns\ user
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